Transfer Uvs do Wings para o Maya

Instalação do programa e seus plugins / Controle da interface / Intercâmbio de formatos

Transfer Uvs do Wings para o Maya

Mensagempor Alex Liki » Qua Mai 10, 2006 1:38 pm

Estou com um problema simples:

Quando modelo alguma coisa no Maya, exporto para o Wings para fazer a UV, reimporto no Maya e tento transferir as Uvs do modelo importado para o modelo nativo do Maya o transfer UV não funciona. O node do comando é criado, mas nada acontece.
A malha está correta, pois eu continuo podendo criar Blend Shapes.
Se eu duplicar a malha importada dentro do Maya e fizer alterações nas Uvs dela eu consigo transferir-las para o modelo do qual ela foi duplicada.

O problema está apenas no transfer da malha exportada do maya com a malha importada do Wings.

Isso já aconteceu com alguém? Alguém faz idéia de por que isso possa estar acontecendo?

abraços
Alex Liki - Modelador Freelance

Meu BLOG
Avatar do usuário
Alex Liki
Assíduo
Assíduo
 
Mensagens: 274
Registrado em: Dom Jul 18, 2004 6:27 am
Localização: São Paulo

Mensagempor XHAOS » Qua Mai 10, 2006 2:27 pm

Oi Alex, tudo bem?


Isso já aconteceu com alguém? Alguém faz idéia de por que isso possa estar acontecendo?


Não tenho idéia, mas vc está importando em q formato? OBJ? Que tal experimentar o formato FBX e ver se continua acontecendo o mesmo problema?

Uma outra coisa q vc pode tentar fazer é importar a malha pro maya...re-exportar a malha...e depois trazê-la para o maya novamente. Alguns problemas de compatibilidade de malhas entre diferentes programas se resolvia assim antigamente...mas não sei se funciona com o maya.

Alex, aproveita q vc vai fazer mais alguns testes e tenta o seguinte:
Quando for importar para o MAYA, desabilite o "Create Multiple Objects" selecionando FALSE na Import Options Box.
Parece q o Maya tende a "renumerar/reoordenar" as faces e os vértices qdo importa um objeto no formato .obj, com isto pode ser q ele esteja reconhecendo a malha importada como diferente por conta desta geometrias modificada e por isso não reconhecendo o mapeamento uv do wings...e se for este o caso, desabilitando o "Create Multiple Objects" pode ajudar a manter a numeração correta. Este processo é mais ou menos o mesmo q te falei lá com aquele problema com os blend shapes lembra-se? a origem do problema pode ser este...mas isto é só um chute...testa aí e depois dá um retorno pra gente ok?

P.S.: Obrigado pela tua MP...parece q eu vou levar o mesmo tempão pra te responder...hehehe


Depois dá um retorno pra gente, ok? :wink:


Abração


X
---------------------------------------------------------
XHAOS
Veterano
Veterano
 
Mensagens: 433
Registrado em: Seg Mai 31, 2004 11:20 pm

Mensagempor Alex Liki » Qui Mai 11, 2006 2:09 pm

XHAOS meu velho, novamente muito obrigado pela ajuda! (vc sempre dá um help quando a coisa aperta).

Bem, eu exportei a malha em .obj do maya e fiz a mesma coisa quando exportei do Wings. Vc estava certo quanto ao seu palpite do "Create Multiple Objects", na verdade era justamente por desligar essa opção que eu conseguia realizar os Blend Shapes normalmente (nós pensamos da mesma maneira nesse aspecto). Mas esse procedimento era exatamente o que eu estava fazendo e consequentemente, não conseguindo usar o transfer UV.
Exportei em .fbx tbm, mas os resultados foram os mesmos. O problema parece estar na hora que a malha sai do Wings e volta para o Maya.
De qualquer forma vou mandar essas malhas para um dos caras do R&D aqui do trampo para ver se ele descobre o que possa estar acontecendo.

obrigado pela ajuda

abraços
Alex Liki - Modelador Freelance

Meu BLOG
Avatar do usuário
Alex Liki
Assíduo
Assíduo
 
Mensagens: 274
Registrado em: Dom Jul 18, 2004 6:27 am
Localização: São Paulo

Mensagempor XHAOS » Qui Mai 11, 2006 3:45 pm

Oi Alex, boa tarde!

De qualquer forma vou mandar essas malhas para um dos caras do R&D aqui do trampo para ver se ele descobre o que possa estar acontecendo.


Pois é Alex, quando receber a resposta do carinha do R&D dá um retorno pra gente, ok? Ainda não tive dificuldades em exportar pra outros programas uma malha do wings conservando o mapeamento...mas já tive a necessidade de transferir um UV mapping de uma malha pra sua cópia internamente no wings e não consegui descobrir um jeito. Se não me engano o uvmapper pro tem este recurso (bem como outros softwares comerciais).

Uma outra coisa q vc pode tentar (mais um chute, já no espírito da copa do mundo :mrgreen: ) é jogar a malha no zbrush antes de levar pro maya. Me lembro q existia um script do zbrush q resolvia os problemas de compatibilidade nas malhas q eram exportadas pro maya (não sei se na versão .2 este recurso já está incorporado na rotina de exportação do zbrush).


Valeu Alex, um abraço.




X

----------------------------------------------------
XHAOS
Veterano
Veterano
 
Mensagens: 433
Registrado em: Seg Mai 31, 2004 11:20 pm

Mensagempor Alex Liki » Qui Mai 11, 2006 5:27 pm

Então Xhaos, eu consigo exportar a malha do Wings para o Maya conservando o mapeamento, o problema é tentar transferir as UVs dessa malha importada para a malha base criada no Maya. (desculpe-me se estiver sendo repetitivo, mas achei que estava sendo um pouco confuso). Na prática isso não é um grande problema, uma vez que o procedimento normal é fazer as UVs antes do riigging (e mesmo se fosse depois é possível substituir as malhas no rigging conservando o Skinning).
Eu fiquei intrigado com o motivo pelo qual essa tranferência de UVs não acontece. De fato alguma coisa acontece com a malha e impede esse processo. Minha vontade em solucionar esse problema reside na possibilidade de outros problemas estarem relacionados à importação/exportação de arquivos do Wings / Maya.

Vou tentar a solução de exportar pelo ZBrush.

Pode deixar que assim que eu descobrir o motivo eu aviso.

abração
Alex Liki - Modelador Freelance

Meu BLOG
Avatar do usuário
Alex Liki
Assíduo
Assíduo
 
Mensagens: 274
Registrado em: Dom Jul 18, 2004 6:27 am
Localização: São Paulo

Mensagempor Fonte Boa » Sex Mai 12, 2006 10:10 am

Olá, Alex! Curiosamente encontrei um caso quase idêntico ao seu em
http://www.deathfall.com/modules.php?op ... d&tid=1260

Links como os seguintes, mostram que parece haver um problema na importação de UVs no Maya:
http://www.newtek.com/forums/archive/in ... -1361.html
http://206.145.80.239/zbc/showthread.php?t=16979 (esse inclusive tem um usuário de Wings que disse que também não conseguia)
http://206.145.80.239/zbc/showthread.php?t=21038

Talvez o caminho via ZB permita recuperar as UVs..

Estou tentando conseguir ajuda sobre o problema.

abração
Fonte Boa
Avatar do usuário
Fonte Boa
Administrador
Administrador
 
Mensagens: 2226
Registrado em: Seg Mai 31, 2004 11:58 pm

Mensagempor Alex Liki » Dom Mai 14, 2006 6:04 pm

Valeu pelos links Fonte :wink:
As UVs estão sendo exportadas e importadas corretamente, o único problema é o fato de qque eu não consigo transferi-las para outra malha idêntica. Ainda não obtive uma resposta do pessoal do R&D, mas assim que tiver daremos um fim a esse problema.

Ainda preiso tentar exportar para o Zbrush.

abração e muito obrigado pela ajuda
Alex Liki - Modelador Freelance

Meu BLOG
Avatar do usuário
Alex Liki
Assíduo
Assíduo
 
Mensagens: 274
Registrado em: Dom Jul 18, 2004 6:27 am
Localização: São Paulo


Voltar para INSTALAÇÃO, CONFIGURAÇÃO E INTEGRAÇÃO

Quem está online

Usuários navegando neste fórum: Nenhum usuário registrado e 3 visitantes

cron